2014年02月18日

SakuttoBookでXcode 5を使って申請する−SakuttoBookのリベンジ5

 今年の2月(2014年)からiTunes Connectでの申請はXcode 5でなければならないようになった。昨年の12月に案内があったようだが、予定通りに施行された。申請だけでなく、アップデートもXcode 5でしかできないようになった。SDKもiOS7のSDKが必要となり、アプリもiOS7に最適化したものが必要となる。こうしてアップデートされない過去のアプリはデバイスにインストールできなくなっていく。

 SakuttoBookは現状ではXcode 4.6.xで使って頂いているが、こうなるとXcode 5(現在の最新版は5.0.2)で申請するしかない。Xcode 5でビルドは可能でアプリ自体は踏査する。ただし問題があって、Xcode 5でビルドすると、アプリ内課金が正しく動作しないのである。仕方がないのでアプリ内課金を使わないバージョンでアプリを申請してみた。

詳しくはこちらから

 


posted by 上高地 仁 at 20:49 | Comment(0) | TrackBack(0) | ニュース&トピック | このブログの読者になる | 更新情報をチェックする
この記事へのコメント
コメントを書く
お名前: [必須入力]

メールアドレス: [必須入力]

ホームページアドレス:

コメント: [必須入力]

認証コード: [必須入力]


※画像の中の文字を半角で入力してください。

この記事へのトラックバック
×

この広告は180日以上新しい記事の投稿がないブログに表示されております。